Skip to content

Available High Level SDKs

The following Software Development Kits (SDKs) have been created to allow developers to create Distributed Applications on top of the DCore block chain without requiring them to understand C++ and the complex and advanced internal structures of DCore technology.

Current High Level SDKs

SDKs have currently been created for JavaScript / Typescript (TypeScript is a compatible extension of JavaScript), Kotlin, PHP and Swift, with other languages being supported in the near future.

DCoreJS-SDK

Dcore development kit for both NodeJS and Javascript browser applications. Written in Typescript.

DCoreKt-SDK

Dcore development kit for both Android & standalone Java platform applications. Written in Kotlin.

DCoreSwift-SDK

Dcore development kit for iOS applications. Written in Swift.

DCorePHP-SDK

Dcore development kit for PHP applications. Written in PHP

The older Javascript SDK is now considered obsolete and is no longer supported.

Example using Typescript

Making transfers on the DCore blockchain using our Typescript SDK is straightforward, as the following example shows:

Access api using websocket and DCoreJS-SDK

import "reflect-metadata";
import * as WebSocket from "isomorphic-ws";
import
{ Credentials }

from "../src/crypto/Credentials";
import
{ DCoreSdk }

from "../src/DCoreSdk";
import
{ AssetAmount }

from "../src/models/AssetAmount";
import
{ ChainObject }

from "../src/models/ChainObject";
import
{ create }

from "rxjs-spy";

// init rxjs-spy and log all tags
const spy = create();
spy.log();

// create api for websocket
const api = DCoreSdk.createForWebSocket(() => new WebSocket("wss://testnet-api.dcore.io/"));
// create account credentials
const credentials = new Credentials(ChainObject.parse("1.2.27"), "5Hxwqx6JJUBYWjQNt8DomTNJ6r6YK8wDJym4CMAH1zGctFyQtzt");
// send 1DCT to account id '1.2.28 (public-account-10)' with encrypted 'hello memo' memo
const disposable = api.accountApi.transfer(credentials, "public-account-10", new AssetAmount(100000000), "hello memo")
.subscribe((confirmation) => console.log(confirmation.id));

Obsolete SDKs

These obsolete SDKs are no longer supported or updated. We strongly discourage their use in new development projects.

However, we appreciate that some developers might need to support legacy software built using these old SDKs and supply their details here:

Low Level SDK (OBSOLETE)

  • dcorejs-lib - Can be used to construct, sign and broadcast transactions in JavaScript, and to easily obtain data from the blockchain via public APIs. The workflow is more difficult than in the case of dcorejs, but it is more convenient to modify, reuse and implement your own solutions.

High Level SDK (OBSOLETE)

  • dcorejs - Javascript library to work with Dcore blockchain network. The work with this SDK is much easier than with dcorejs-lib, but to get more availability to modify code, it is better to use the latter (low level SDK).

Source Code

Open Source (MIT License) source codes for dcorejs-lib and dcorejs can be found here.

Examples for Older SDKs

Examples for building and usage for dcorejs-lib and dcorejs are available are available here.